WRF-ARW 3.4 winds too strong in nest when it is started after parent domain

Compiling NMM/ARW code for EMS system, upgrading WRF cores on your own, changing EMS scripts to suit your particular needs, and other modifications to original EMS distribution goes in this forum. These are officially unsupported actions.
meteoadriatic
Posts: 1512
Joined: Wed Aug 19, 2009 10:05 am

Re: WRF-ARW 3.4 10m wind too strong

Post by meteoadriatic » Fri Apr 27, 2012 1:54 pm

Uhmmm, I have some interesting stuff going on here. I'll copy/paste what I sent to wrfhelp, this is what I found today:

I found that, if I start both mother domain and nest in the same time, for example:
start_hour 06, 06

then there is NO PROBLEM at all.

But, if I use different start time for nest than for the mother domain, for example:
start_hour 06, 18

then there is described issue with MUCH overestimated 10m winds in nest domain.


I'm now attaching two outputs for the same date/time for the 10m wind speed into nested domain, completely the same case, everything is the same just different starting nest time. As you can see the file named "noissue" has very natural wind speed distribution (has details), but file named "issue" lacks details (like there is missing topografy resolution, or like there is missing any friction from the ground) and speeds are at least double than should be (color bar is m/s in both cases).

I have set in namelist.input
fine_input_stream 0, 2
and
input_from_file T, T

I repeat, this issue is NOT happening if I use ARW v3.3.1 (or any older) binaries istead of v3.4.

Here are attached images for 10m wind speed (same date/time, different runs as described above):

NO ISSUE case:
both mother and nest started at the same time
start_hour 06, 06

Image

ISSUE case:
nest started 12 hours after mother domain
start_hour 06, 18

Image


And yes, issue only happens in nest, not in mother domain as I can see.

surgeon
Posts: 44
Joined: Wed Dec 08, 2010 1:34 pm
Location: Poland
Contact:

Re: WRF-ARW 3.4 winds too strong in nest when it is started after parent domain

Post by surgeon » Sat Apr 28, 2012 5:09 pm

Is there any reason to use different start_hour in parent and nested?

meteoadriatic
Posts: 1512
Joined: Wed Aug 19, 2009 10:05 am

Re: WRF-ARW 3.4 winds too strong in nest when it is started after parent domain

Post by meteoadriatic » Sat Apr 28, 2012 5:16 pm

surgeon wrote:Is there any reason to use different start_hour in parent and nested?
Yes, I save some computing time by not running nests first 6 (or 12) hours of simulation. If there is no way to solve this I will probably run them all from analysis time but this looks to me like a bug in new ARW code. I'm waiting to hear from wrfhelp...

wrf_model
Posts: 53
Joined: Wed Feb 17, 2010 9:38 pm

Re: WRF-ARW 3.4 winds too strong in nest when it is started after parent domain

Post by wrf_model » Mon Apr 30, 2012 3:46 pm

Dears,

I try WRF-ARW version 3.4 without WRFEMS. If you use YSU for pbl scheme, you must use "topo_wind = 1".

<<topo_wind = 1: Topographic correction for surface winds to represent extra drag from sub-grid topography and enhanced flow at hill tops (Jimenez and Dudhia, JAMC 2012). Works with YSU PBL only. New in Version 3.4.>>

meteoadriatic
Posts: 1512
Joined: Wed Aug 19, 2009 10:05 am

Re: WRF-ARW 3.4 winds too strong in nest when it is started after parent domain

Post by meteoadriatic » Mon Apr 30, 2012 4:19 pm

Hello,

I know about new option topo_wind and I tried it, without luck. I did tested it with YSU, but I'm pretty sure that it doesn't do anything to this issue. As I found the issue happen only when nest is started few hours after parent domain. However I'll try this again to be sure.

wrf_model
Posts: 53
Joined: Wed Feb 17, 2010 9:38 pm

Re: WRF-ARW 3.4 winds too strong in nest when it is started after parent domain

Post by wrf_model » Mon Apr 30, 2012 6:29 pm

meteoadriatic wrote:Hello,

I know about new option topo_wind and I tried it, without luck. I did tested it with YSU, but I'm pretty sure that it doesn't do anything to this issue. As I found the issue happen only when nest is started few hours after parent domain. However I'll try this again to be sure.
Have you right results with mean sea level pressure?

meteoadriatic
Posts: 1512
Joined: Wed Aug 19, 2009 10:05 am

Re: WRF-ARW 3.4 winds too strong in nest when it is started after parent domain

Post by meteoadriatic » Mon Apr 30, 2012 7:41 pm

wrf_model wrote:
meteoadriatic wrote:Have you right results with mean sea level pressure?
As far as I can tell, MSL field isn't affected. It is little bit different, but gradients are not any stronger so that this will be a cause of doubling the wind speed. No, it is more like absence of friction or something like that. I'm running some new simulations that wrfhelp suggested right now.
wrf_model wrote:If you use YSU for pbl scheme, you must use "topo_wind = 1".
Tried now again to be sure, with bl_pbl_physics = 1 (YSU) and topo_wind = 1, no improvement.

Now waiting for wrfhelp again. As they requested two test runs with
input_from_file T, F,
fine_input_stream 0, 2,


and
input_from_file T, F,
fine_input_stream 0, 0,


(no improvement with these options).

meteoadriatic
Posts: 1512
Joined: Wed Aug 19, 2009 10:05 am

Re: WRF-ARW 3.4 winds too strong in nest when it is started after parent domain

Post by meteoadriatic » Fri Aug 17, 2012 6:41 am

WRF v3.4.1 is issued today, it looks it contains fix for this problem:
- YSU: a bug fix for nest starting at later time due to introduction of 'topo_wind' option, even if the option isn't used.
http://www.mmm.ucar.edu/wrf/users/wrfv3 ... 3.4.1.html

I'll see, soon.

meteoadriatic
Posts: 1512
Joined: Wed Aug 19, 2009 10:05 am

Re: WRF-ARW 3.4 winds too strong in nest when it is started after parent domain

Post by meteoadriatic » Wed Aug 22, 2012 7:03 am

Yes, it is fixed now. Case closed finally.

isakhar13
Posts: 1
Joined: Tue Aug 02, 2016 4:00 am

Re: WRF-ARW 3.4 winds too strong in nest when it is started after parent domain

Post by isakhar13 » Tue Aug 02, 2016 4:02 am

meteoadriatic wrote:Yes, it is fixed now. Case closed finally.
Hi meteoadriatic,

Could you please attach your namelist.input?

Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests