Unable to identify network interface

Questions and other topics related to UEMS 18.
Post Reply
tedd
Posts: 3
Joined: Wed Dec 28, 2011 1:31 pm

Unable to identify network interface

Post by tedd » Sun Jan 14, 2018 8:50 am

Hi,

I cannot seem to run ems_run.
It always results in this error, both in my domains and in the benchmark.

Code: Select all

Error: Unable to identify network interface for 127.0.0.1.
Can't use an undefined value as an ARRAY reference at /mnt/ems/uems/strc/Urun/Rutils.pm line 34.
It has also happened in V15 (I've got the latest V18) under Debian and also previously under Arch.

Am I missing a software package or something?

Thanks.

wxgeek999
Posts: 3
Joined: Tue Jan 16, 2018 10:48 pm

Re: Unable to identify network interface

Post by wxgeek999 » Wed Jan 17, 2018 1:21 am

Just wondering if you solved this problem? I had the same result.

Jimmy

wxgeek99
Posts: 3
Joined: Thu Mar 05, 2015 7:57 pm

Re: Unable to identify network interface

Post by wxgeek99 » Wed Jan 24, 2018 2:51 am

I had attempted this using Ubuntu 17.10. One day Ubuntu stopped connecting to WIFI.
Not sure why, Since I did not have a particular preference for Ubuntu, I switched to Fedora 27.
The benchmark routine then ran just fine. Also the problem I had with geogrid failing on the
NMM grid. I solved that by switching to an ARW grid. Getting grib/grads and gempak output
now!!!

Jimmy

tedd
Posts: 3
Joined: Wed Dec 28, 2011 1:31 pm

Re: Unable to identify network interface

Post by tedd » Fri Jan 26, 2018 2:38 am

I was missing a package.
UEMS requires net-tools to fix this error, as found by meteo60 in this thread:
http://wrfems.info/viewtopic.php?f=12&t=1206

This should fix the problem for any other distribution as well.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest