IMPORTANT: Use correct installer script for your EMS version

Forum dedicated to older versions of EMS package (WRFEMS v3.2, v3.1 or older). Support is user-to-user based, so please help others if you can.
Post Reply
meteoadriatic
Posts: 1510
Joined: Wed Aug 19, 2009 10:05 am

IMPORTANT: Use correct installer script for your EMS version

Post by meteoadriatic » Mon Sep 12, 2011 8:21 am

Really a LOT of support requests come from this issue, and this is probably the most common mistake new WRF EMS users make. I'll try to explain here why this happens and what you can do to avoid these problems.


*************************************************************************************************************
*************************************************************************************************************

PART 1: Why it doesn't work for me?

1.) You can't use installer script written for WRF EMS v3.1 and try to install v3.2 using it. And vice versa, you can't use installer script dedicated for v3.2 and try to install v3.1. No, it won't work either!

2.) You MUST specify WRF EMS version you want to install when you run ems_install.pl installer script. This is the key point here, because the script is not aware about being itself unable to install unrelated version correctly. So if you don't specify version, the script will guess something; often it will be incorrect version, and, installation will fail (that is, it will be incomplete). I know, this sounds strange and stupid but... that's how things are for now.


*************************************************************************************************************
*************************************************************************************************************

PART 2: What can I do?

So, what would be correct command to install WRF EMS?

First step:

Change dir into the path where your installer script is located and run:

Code: Select all

./ems_install.pl --help
to see all available options you have, and read whole output! Important stuff is there, that will save you from a lot of potential trouble.


When you do that, do next steps to actually install your software:

Code: Select all

./ems_install.pl --list
to see the list of available versions and then:

Code: Select all

./ems_install.pl --install 3.1.1.5.1
if you have installer for v3.1, or

Code: Select all

./ems_install.pl --install 3.2.1.5.34
(or whatever the --list gives you as newest v3.2 option)
if you have installer for v3.2

So, yes, YES, specify version you want to install using --install argument! Even though the ems_install.pl --help says it it optional, DO IT. Seriously. And I repeat, only install v3.1.x.x.x if you have 3.1 installer, or, v3.2.x.x.x if you have 3.2 installer.


*************************************************************************************************************
*************************************************************************************************************

PART 3: Which installer do I have?

How to know which installer version do you have? Simply, run:

Code: Select all

./ems_install.pl --help
and look at the end of output. If you see:

Code: Select all

    And most importantly:

          % ems_install.pl --help     For help, love, understanding, and this menu again
Then it is v3.1 installer


If you see instead:

Code: Select all

    And most importantly:
    
        a. Visit - http://strc.comet.ucar.edu/wrf/usersguide/emsguide_chapter02.pdf
        c. Run   - ems_install.pl --help       For this menu again
Then it is v3.2 installer


*************************************************************************************************************
*************************************************************************************************************

Hope this clarifies mess with versioning and installing right one.

StefanD
Posts: 26
Joined: Wed Aug 17, 2011 7:50 pm

Re: IMPORTANT: Use correct installer script for your EMS ver

Post by StefanD » Tue Sep 13, 2011 10:02 am

Thank you for your helpful tips! I had the same problem. The install script for 3.2 does not work with 3.1.1.5.1. The tricky part is that during installation there was no error (at least I saw none ;)). The problem arises when you try to create a domain it states that there are some folders missing. With 3.2.1.5.34.beta it works fine!

Kind Regards
Stefan

nebojsa
Posts: 133
Joined: Sun Mar 21, 2010 3:40 pm

Re: IMPORTANT: Use correct installer script for your EMS ver

Post by nebojsa » Wed Sep 14, 2011 9:15 am

Can someone send me this 3.2 ems_install.pl please.

Thanks!

Nebojsa
nebojsa.subanovic@meteo-info.hr

buongiornometeo
Posts: 3
Joined: Sun Aug 08, 2010 10:16 am

Re: IMPORTANT: Use correct installer script for your EMS ver

Post by buongiornometeo » Wed Oct 12, 2011 9:41 am

can anyone send me the script for 3.2 ???? giuse83@gmail.com

jackq7a
Posts: 10
Joined: Tue Oct 18, 2011 2:40 pm

Re: IMPORTANT: Use correct installer script for your EMS ver

Post by jackq7a » Wed Oct 19, 2011 2:14 am

Is there any alternative way to get the EMS Installer? I know Robert is very busy(I've been waiting since June) so if someone else has another way to get it, could you let me know? Is there any way someone can email it to me or is there another place to download?

Thanks,
Jack

meteoadriatic
Posts: 1510
Joined: Wed Aug 19, 2009 10:05 am

Re: IMPORTANT: Use correct installer script for your EMS ver

Post by meteoadriatic » Wed Oct 19, 2011 5:08 am

Yes, some of us can forward it to your mail. I will be away from keyboard now for three days, if nobody send it to you until I get back, PM me.

jackq7a
Posts: 10
Joined: Tue Oct 18, 2011 2:40 pm

Re: IMPORTANT: Use correct installer script for your EMS ver

Post by jackq7a » Wed Oct 19, 2011 1:15 pm

Thanks, I can wait for three days. :mrgreen: I'll pm you my email. Many thanks!

meso
Posts: 10
Joined: Fri Feb 22, 2013 10:30 pm

Re: IMPORTANT: Use correct installer script for your EMS version

Post by meso » Sat Mar 02, 2013 7:18 pm

1.) You can't use installer script written for WRF EMS v3.1 and try to install v3.2 using it. And vice versa, you can't use installer script dedicated for v3.2 and try to install v3.1. No, it won't work either!

Ops, I didn't clarify a release when I ran the script. Furthermore, I didn't realize which version of the installer script I had when I done so.

Anyway, it installed completely (it tells me) version 3.1.1.5.1 (the most current official release) however after checking the installer script it looks like I had v3.2??

I though that wasn't possible? Also, v3.2 looks to be installing beta releases only, correct? (I take that from .beta appended to the end of each release.) Should I scrap this install I re-run the latest v3.2 (3.2.1.5.45.beta)?

Thanks!

meteoadriatic
Posts: 1510
Joined: Wed Aug 19, 2009 10:05 am

Re: IMPORTANT: Use correct installer script for your EMS version

Post by meteoadriatic » Sat Mar 02, 2013 8:23 pm

I'm not sure if it changed from the time I wrote this. Maybe new installer v3.2 releases successfully install v3.1 also. I didn't tried it! However, v3.1 installer for sure won't install v3.2 correctly.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest