GRADS MAPS ARE NOT CREATED - PROBLEM

Forum dedicated to older versions of EMS package (WRFEMS v3.2, v3.1 or older). Support is user-to-user based, so please help others if you can.
Post Reply
bsekirarski
Posts: 18
Joined: Thu Dec 23, 2010 8:51 am

GRADS MAPS ARE NOT CREATED - PROBLEM

Post by bsekirarski » Tue Mar 20, 2012 2:49 pm

After automatc run of
plot_grads.tcsh (all steps before in postems are OK I think!
I HAVE TIS IN A LOG FILE: ------------------------------------------------------------------------------------------
Running /home/usr1/wrfems/wrfems/util/grads/products/kumar/plot_grads.tcsh to generate Web pages for domain 01

/home/usr1/wrfems/wrfems/util/bin/wgrib: Exec format error. Binary file not executable.
...
/home/usr1/wrfems/wrfems/util/bin/wgrib: Exec format error. Binary file not executable.
PGFIO-F-209/OPEN/unit=11/'OLD' specified for file which does not exist.
File name = hgt_925.dat
In source file hght_maxmin.f, at line number 34
/home/usr1/wrfems/wrfems/util/bin/wgrib: Exec format error. Bi.......

------------------------- AND
WHEN I TRY TO RUN wgrib: ------------------------------------------------------------------------------------------
usr1@ubuntu1010desktop-> ./wgrib
./wgrib: Exec format error. Wrong Architecture.

BUT
./wgrib.32 AND ./wgrib2
ARE STARTED OK

ANY HELP PLEASE
Boris

bsekirarski
Posts: 18
Joined: Thu Dec 23, 2010 8:51 am

Re: GRADS MAPS ARE NOT CREATED - PROBLEM

Post by bsekirarski » Tue Jul 17, 2012 2:15 pm

After RUN I have
1
post_grads2web.log WITH:
Running /home/usr1/wrfems/wrfems/util/grads/products/kumar/plot_grads.tcsh to generate Web pages for domain 01
Creating Images for field: hght
mv: No match.
Creating Images for field: temp
mv: No match.
Creating Images for field: relh
mv: No match.
Creating Images for field: wind
mv: No match.
Creating Images for field: vvel
mv: No match.
Creating Images for field: rvor
mv: No match.
Creating Images for field: prec
mv: No match.
Creating Images for field: mslp
mv: No match.
View the details of your model run with:
firefox file:///home/usr1/wrfems/wrfems/runs/euro1/emsprd/grads/d01htm/index.html
End of GrADS image generation
------------------------------------------------------------
2
AND one EMPTY post_grads2web.log

3
ALL FILES ARE CREATED EXCEPT IMAGES IN GRADS OUTPUT

ANY HELP

bsekirarski
Posts: 18
Joined: Thu Dec 23, 2010 8:51 am

Re: GRADS MAPS ARE NOT CREATED - PROBLEM

Post by bsekirarski » Fri Jul 20, 2012 8:22 pm

I have syntax error in plot_grads.tcsh


Please! What is wrong here?
sed -e "s^Xtemplate^\"$fn"^g" -e "s/XXXX/$ft/g" -e "s/YYYY/$fint/g" ${gwdir}/scripts/${fld}.gs > temp.gs

I try this and it is also wrong.
sed -e "s^Xtemplate^\"$fn^g" -e "s/XXXX/$ft/g" -e "s/YYYY/$fint/g" ${gwdir}/scripts/${fld}.gs > temp.gs

Any advice?

meteoadriatic
Posts: 1566
Joined: Wed Aug 19, 2009 10:05 am

Re: GRADS MAPS ARE NOT CREATED - PROBLEM

Post by meteoadriatic » Sat Jul 21, 2012 11:17 am

bsekirarski wrote:------------------------- AND
WHEN I TRY TO RUN wgrib: ------------------------------------------------------------------------------------------
usr1@ubuntu1010desktop-> ./wgrib
./wgrib: Exec format error. Wrong Architecture.
What CPU and OS version do you have?

bsekirarski
Posts: 18
Joined: Thu Dec 23, 2010 8:51 am

Re: GRADS MAPS ARE NOT CREATED - PROBLEM

Post by bsekirarski » Sun Jul 22, 2012 9:22 am

It is Ubuntu 10.10 on VM on core 2 duo.

DURING INS I HAS WRONG wgrib.

I borrow THE RIGH ONE (JUST COPY) from other test WRFEMS installation now RUN WITH NO PROBS)

I STILL HAVE PROBLEM ONLY IN AUTOMATED IMAGE CREATION
(ALL GRADS CTL AND OTHER FILES ARE CREATED)

iT CAN BE
SED COMMAND SHOW INTERRUPTING IN EDITOR Syntax highlighting WHEN IS IN ORIGINAL
#ORIGINAL sed -e "s^Xtemplate^\"$fn"^g" -e "s/XXXX/$ft/g" -e "s/YYYY/$fint/g" ${gwdir}/scripts/${fld}.gs > temp.gs

i HAVE ONE SUGESTION TO AVOID '' " '' SO I AM TRY TODAY WITH
sed -e ´s^Xtemplate^\´$fn´^g´ -e ´s/XXXX/$ft/g´ -e ´s/YYYY/$fint/g´ ${gwdir}/scripts/${fld}.gs > temp.gs

PLEASE HAELP

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest