UEMS wind parametrization

Questions and other topics related to UEMS 15.
skosecki
Posts: 20
Joined: Wed Aug 31, 2016 7:37 am

Re: UEMS wind parametrization

Post by skosecki » Wed Jan 11, 2017 10:49 am

Hello again,

I would like to poste that one of my tries was considering change of Land Surface Model. I wanted to use 4 - Noah-MP (multi-physics) Land Surface Model, since I was using 2 - Noah before. I hope that Noah-MP would be a better choice in my quite complex Arctic area.. Unfortunately I got the error "Invalid Memory Reference - Seg Fault" while running. I've tried several times to repeat, I've also run ems_prep again.. and nothing works.
Maybe, because this setup requires additional information from run_physics_noahmp.conf which doesn't exist in my domain/conf/ems_run ?

EDIT: Also the thing that's concerns me is that "topo_wind" option "Requires additional information from geogrid". So maybe that's why there is no significant wind bias improvement ?

Regards!

meteoadriatic
Posts: 1560
Joined: Wed Aug 19, 2009 10:05 am

Re: UEMS wind parametrization

Post by meteoadriatic » Wed Jan 11, 2017 6:46 pm

NOAH-MP is still considered as not ready from operational use in my opinion. NOAH is stable and better choice. There are some direct comparision studies where MP version didn't show much reasons to use (it is slower and not stable - as you see):
The Noah-MP LSM is an advancement in the representation of physical processes; however, because it is relatively new to the research community, additional modifications and tuning may be necessary prior to operational implementation.
http://www.dtcenter.org/eval/meso_mod/a ... REPORT.pdf

Note: It is study done with 3.5.1 version but I don't see much improvements from that.

For topo_wind, find your GEOGRID.TBL.ARW that is used for creating domain. Find section that starts with
name = VAR_SSO

If you have it, and if you have mentioned directories like varsso_10m and so on in your geog directory (and if you do not see errors in geogrid.log about varsso) then your domain has everything to run topo_wind. I believe in EMS everything is set up correctly by default for that.

skosecki
Posts: 20
Joined: Wed Aug 31, 2016 7:37 am

Re: UEMS wind parametrization

Post by skosecki » Thu Jan 12, 2017 10:11 am

It is empty :cry: .. the variable VAR_SSO in my domain geo_em.d0*.nc files.
Image
However I found GEOGRID.TBL.ARW .. although I can't find my geogrid.log (I've created this domain on other computer)
If I understand it.. my domain is out of data range? The part of geog index file:
dx = 0.00833333
dy = 0.00833333
known_x = 1.0
known_y = 1.0
known_lat = -59.99583
known_lon = -179.99583
wordsize = 4
tile_x = 600
tile_y = 600
I should check this earlier.. Now maybe I'll try with other PBL schemes?

meteoadriatic
Posts: 1560
Joined: Wed Aug 19, 2009 10:05 am

Re: UEMS wind parametrization

Post by meteoadriatic » Thu Jan 12, 2017 11:26 am

skosecki wrote:I(I've created this domain on other computer)
Then all I wrote about GEOGRID.TBL.ARW and log, you need to find and check on that computer.

VAR_SSO should not be empty. It should have data ranging from 0 to about 500.000 meters2 MSL. You definitely need to recreate that domain....

skosecki
Posts: 20
Joined: Wed Aug 31, 2016 7:37 am

Re: UEMS wind parametrization

Post by skosecki » Thu Jan 12, 2017 2:41 pm

I've created the new one for test. Still the same problem VAR_SSO = 0, geogrid.log shows no errors. It seems what I expected, that the spatial range of those data don't cover Svalbard. I could try to update the EMS, but I doubt that it'll resolve my problem.

Either way - I'll try to create new domain and extend parent domain to north, also I would enlarge the child domains, for aprox the same nx,ny sizes as the parent, so I could use more processor cores in computations and probably refine my results.

Cheers!

meteoadriatic
Posts: 1560
Joined: Wed Aug 19, 2009 10:05 am

Re: UEMS wind parametrization

Post by meteoadriatic » Thu Jan 12, 2017 3:53 pm

Let me try. Give me your namelist.wps, I will see what I get, If I get data correctly I'll upload domain for you so you can use it until you find a way to fix your.

skosecki
Posts: 20
Joined: Wed Aug 31, 2016 7:37 am

Re: UEMS wind parametrization

Post by skosecki » Fri Jan 13, 2017 10:15 am

I send it in the private message.
I'm very grateful!
I chose polar map projection, could it be the issue?

meteoadriatic
Posts: 1560
Joined: Wed Aug 19, 2009 10:05 am

Re: UEMS wind parametrization

Post by meteoadriatic » Fri Jan 13, 2017 12:00 pm

Got it.

Polar is not problem... unfortunatelly you were right. There is no data that further north in geog files.

Compared landmask and var_sso around your area - nothing in your area in var_sso unfortunatelly:

Image

So there is no point using topo_wind there...

skosecki
Posts: 20
Joined: Wed Aug 31, 2016 7:37 am

Re: UEMS wind parametrization

Post by skosecki » Fri Jan 13, 2017 12:09 pm

How about, I go to the 800m resolution in my child domains and try without PBL in those, just 3d diffusion. Get into eddy-resolving is quite exciting :)I would change my parent to child domain ratio from 3 to 5? Leave YSU for parent domain?

meteoadriatic
Posts: 1560
Joined: Wed Aug 19, 2009 10:05 am

Re: UEMS wind parametrization

Post by meteoadriatic » Fri Jan 13, 2017 12:18 pm

Never tried that. Go on if you succeed, report some results :)

However if you want quality your domain sizes are pretty small. They should be at least 100x100 grid points each.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest