Segmentation Fault running benchmark with ems_prep

With soon inclusion of the NEMS NMM-B model into the EMS package, WRF EMS changes its name and becomes UEMS.
Post Reply
e24744
Posts: 3
Joined: Wed Mar 22, 2017 10:10 pm

Segmentation Fault running benchmark with ems_prep

Post by e24744 » Fri Mar 24, 2017 9:39 pm

I am running ems_prep --benchmark on RedHat 7.3 Linux workstation (standalone) and Bash shell and receiving a Segmentation fault when it tries to run metgrid. the system has 24Gb memory and single 4 core cpu. I have changed the stack size to unlimited but error remains the same. See screen output below.

* Interpolating fields from the initialization to the computational domain (3 CPUs)sh: line 1: 7455 Segmentation fault
(core dumped) /dsk1/uems/util/mpich2/bin/mpiexec.gf -exitinfo -n 3 -maxtime 599 /dsk1/uems/bin/metgrid > /dsk1/uems/util/benchmark/27april2011/log/prep_metgrid.log 2>&1
- Failed (139)


! In metgrid (139) - This is not looking good!

prep_metgrid2.log contains some setup info but prep_metgrid.log is empty.

Any other changes to ulimit required? Or other thoughts?

meteoadriatic
Posts: 1510
Joined: Wed Aug 19, 2009 10:05 am

Re: Segmentation Fault running benchmark with ems_prep

Post by meteoadriatic » Fri Mar 24, 2017 10:12 pm

No, ulimit should not has much with metgrid I guess. Are you able to run anything? Like for example "benchmark case" from UEMS?
http://strc.comet.ucar.edu/software/new ... endixB.pdf

e24744
Posts: 3
Joined: Wed Mar 22, 2017 10:10 pm

Re: Segmentation Fault running benchmark with ems_prep

Post by e24744 » Sat Mar 25, 2017 7:37 pm

I am trying to run the benchmark case starting with the command "ems_prep --benchmark" as outlined in the appendix. This is where I ran into the segmentation fault problem. General utilities like "sysinfo" work fine. All environment variables appear to be defined. I am using 15.89.3 of UEMS . Should I start the benchmark case differently?

e24744
Posts: 3
Joined: Wed Mar 22, 2017 10:10 pm

Re: Segmentation Fault running benchmark with ems_prep

Post by e24744 » Sat Mar 25, 2017 7:44 pm

I believe I have the ARW core, but the attachment that is given in the previous post is not the same as the one I downloaded from the UEMs site. the benchmark case is 27-april-2011. I also has 2 nested domains, however I am only trying to run the main domain.

meteoadriatic
Posts: 1510
Joined: Wed Aug 19, 2009 10:05 am

Re: Segmentation Fault running benchmark with ems_prep

Post by meteoadriatic » Sun Mar 26, 2017 10:26 am

Thas is not good. What CPU you have?

Did ungrib created intemediate files correctly? If it failed somewhere, that might be the cause of metgrid to crash like that.

Also, for ulimit, it is set at unlimited value at runtime through EMS script, so you don't need to worry about that at all.

fsugrizz
Posts: 8
Joined: Sat Jan 30, 2016 2:26 pm

Re: Segmentation Fault running benchmark with ems_prep

Post by fsugrizz » Thu Jun 08, 2017 3:14 pm

Is there any update to this? I just got the same error message.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest