ems_post process

Questions and other topics related to UEMS 15.
Post Reply
pskunjeer
Posts: 6
Joined: Thu Aug 13, 2015 2:38 pm

ems_post process

Post by pskunjeer » Sat Jan 06, 2018 2:23 pm

I have performed the simulation using UEMS and there was no error during the simulation. I have used fnl data for boundary layer and initialization of model run. I have post process the files using ems_post to grib file for every hour. When I see the post process grib files or original wrf_output netcdf files in panoply, all the precipitation filed like rainnc, total accumulated precipitation etc are always shown as zero (i have checked the array in Panoply, it shows precipitation always as zezo for all time step). Actually, there was heavy rain during the simulation period. Pl guide to view the result files.
Image

meteoadriatic
Posts: 1540
Joined: Wed Aug 19, 2009 10:05 am

Re: ems_post process

Post by meteoadriatic » Sat Jan 06, 2018 4:10 pm

If wrfout files does not contain any precipitation, then either WRF does not produce any rain (possible if some very strange/broken physics is used) or does not output them into wrfout (most probably).

If that is the case, let us know the contents of your namelist.wrfm file from static directory, it should give some ideas what to look for.

pskunjeer
Posts: 6
Joined: Thu Aug 13, 2015 2:38 pm

Re: ems_post process

Post by pskunjeer » Thu Feb 01, 2018 6:11 am

I have installed new WRF 18.0 and conducted the new simulations, but the problem remains the same, I don't get any rainfall. I have attached the namelist.wrfm file for more information.


&time_control
start_year = 2013
start_month = 06
start_day = 10
start_hour = 00
start_minute = 00
start_second = 00
end_year = 2013
end_month = 06
end_day = 18
end_hour = 00
end_minute = 00
end_second = 00
interval_seconds = 21600
input_from_file = T
history_interval = 60
history_outname = 'wrfout_d<domain>_<date>'
frames_per_outfile = 1
io_form_history = 2
io_form_input = 2
io_form_restart = 2
io_form_boundary = 2
io_form_auxinput2 = 2
output_ready_flag = F
auxhist1_interval = 0
auxhist2_interval = 0
fine_input_stream = 0
adjust_output_times = T
reset_simulation_start = F
use_netcdf_classic = T
/

&domains
time_step = 40
time_step_fract_num = 0
time_step_fract_den = 100
time_step_dfi = 40
max_dom = 1
s_we = 1
e_we = 100
s_sn = 1
e_sn = 113
s_vert = 1
e_vert = 45
dx = 6900.0000
dy = 6900.0000
grid_id = 1
parent_id = 1
i_parent_start = 1
j_parent_start = 1
parent_grid_ratio = 1
parent_time_step_ratio = 1
grid_allowed = T
numtiles = 1
nproc_x = -1
nproc_y = -1
hypsometric_opt = 2
num_metgrid_soil_levels = 4
num_metgrid_levels = 27
interp_type = 2
extrap_type = 2
t_extrap_type = 2
use_levels_below_ground = T
use_surface = T
lagrange_order = 9
zap_close_levels = 500
lowest_lev_from_sfc = F
force_sfc_in_vinterp = 2
sfcp_to_sfcp = T
smooth_cg_topo = T
rh2qv_wrt_liquid = T
rh2qv_method = 2
p_top_requested = 5000
adjust_heights = F
use_maxw_level = 0
use_trop_level = 0
use_adaptive_time_step = F
/

&dfi_control
dfi_opt = 0
/

&physics
cu_physics = 11
cudt = 5
kfeta_trigger = 1
kf_edrates = 0
mp_physics = 2
mp_zero_out = 0
no_mp_heating = 0
do_radar_ref = 1
shcu_physics = 0
bl_pbl_physics = 1
bldt = 0
grav_settling = 0
topo_wind = 0
ysu_topdown_pblmix = 0
scalar_pblmix = 1
tracer_pblmix = 1
sf_sfclay_physics = 1
isfflx = 1
iz0tlnd = 1
isftcflx = 0
sf_surface_physics = 2
num_land_cat = 21
num_soil_cat = 16
num_soil_layers = 4
surface_input_source = 3
usemonalb = T
rdmaxalb = T
rdlai2d = T
ua_phys = T
sf_surface_mosaic = 1
opt_thcnd = 1
mosaic_cat = 3
tmn_update = 0
sf_urban_physics = 0
ra_lw_physics = 1
ra_sw_physics = 1
radt = 6.90
swint_opt = 1
ra_call_offset = 0
swrad_scat = 1
slope_rad = 0
topo_shading = 0
cu_rad_feedback = T
icloud = 1
sf_ocean_physics = 0
sst_skin = 0
sst_update = 0
fractional_seaice = 0
seaice_albedo_opt = 0
seaice_albedo_default = 0.65
seaice_snowdepth_opt = 0
seaice_snowdepth_min = 0.001
seaice_snowdepth_max = 10.
seaice_thickness_opt = 0
seaice_thickness_default = 3.0
sf_lake_physics = 0
lightning_option = 3
/

&noah_mp
/

&dynamics
non_hydrostatic = T
hybrid_opt = 0
gwd_opt = 0
rk_ord = 3
h_mom_adv_order = 5
h_sca_adv_order = 5
v_mom_adv_order = 3
v_sca_adv_order = 3
moist_adv_opt = 1
scalar_adv_opt = 1
momentum_adv_opt = 1
tke_adv_opt = 1
diff_opt = 1
km_opt = 4
w_damping = 1
diff_6th_opt = 2
diff_6th_factor = 0.25
damp_opt = 0
time_step_sound = 0
use_theta_m = 0
use_q_diabatic = 0
/

&scm
/

&fdda
grid_fdda = 0
/

&tc
/

&fire
/

&bdy_control
spec_bdy_width = 5
spec_zone = 1
relax_zone = 4
spec_exp = 0
specified = T
nested = F
/

&stoch
skebs = 0
perturb_bdy = 0
/

&grib2
/

&namelist_quilt
nio_tasks_per_group = 0
nio_groups = 1
/

&diags
p_lev_diags = 0
z_lev_diags = 0
/

&afwa
afwa_diag_opt = 0
/

&logging
compute_slaves_silent = F
io_servers_silent = F
stderr_logging = 1
/

meteoadriatic
Posts: 1540
Joined: Wed Aug 19, 2009 10:05 am

Re: ems_post process

Post by meteoadriatic » Thu Feb 01, 2018 3:53 pm

Hello,

First thing I found strange is lagrange_order = 9. It should be either 1 od 2.

But I'm not sure if that is your problem.

Can you try completely same configuration but load it with gfsptiles for realtime run?

pskunjeer
Posts: 6
Joined: Thu Aug 13, 2015 2:38 pm

Re: ems_post process

Post by pskunjeer » Sun Feb 04, 2018 2:41 am

Hello meteoadriatic,

I will change the vertical interpolation order (lagrange_order) to linear (1) and try the same run.

pskunjeer
Posts: 6
Joined: Thu Aug 13, 2015 2:38 pm

Re: ems_post process

Post by pskunjeer » Fri Mar 02, 2018 1:03 pm

I have changed the vertical interpolation order but the results are same, there is absolutely no rain shown in rainnc

meteoadriatic
Posts: 1540
Joined: Wed Aug 19, 2009 10:05 am

Re: ems_post process

Post by meteoadriatic » Sat Mar 03, 2018 10:26 am

I wonder do you have any meaningful humidity wihtin model? What do you see in relative humidity (free atmosphere levels) and cloud cover output? If that is also pretty much nothing then I know what is problem.

ilianm
Posts: 3
Joined: Thu Sep 19, 2013 11:16 am

Re: ems_post process

Post by ilianm » Mon Mar 19, 2018 1:41 pm

Hi,
We have a similar problem with RAINC ant the reflectivity fields.
In post files we get only 3d fields of reflectivity on presure surface
In emsupp-cntrl.parm we have a few other refl variables, but they are NILL
In the log files it shows error - Cant find REFD_MAX variable
The fields in wrfout netcdf file are NILL too. They exist, but contain only 0.
Dou you know where they is calculated and why it is missing?
I added the iofiles... .txt in static directory, but i am wrong with variable names - WRFems says that can't fint variable....

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 2 guests