Problems with weasdsfc and snow melt in grib files

All issues/questions about EMS v3.4 package, please ask here.
Post Reply
JFMass
Posts: 4
Joined: Tue Dec 02, 2014 12:50 am

Problems with weasdsfc and snow melt in grib files

Post by JFMass » Tue Dec 02, 2014 1:05 am

Hello everyone,

We recently upgraded to 3.4 and with winter we found out there was a problem with some variables in the grib files. We need values from WEASDsfc and SNOMsfc for a winter flood model, however, while initial water equivalent snow seems okay, the first forecast seem to restart accumulation from 0. For example, I could start with 15mm eq for one point, then forecast hour one resets to 0 and will accumulated from 0 as new snow falls over the region. Also, SNOMsfc has been giving us very negligible values in the ordre of 0.0001 mm despite high temperatures and rain.

We get this issue only when using grib files, values from these two variables are fine when we use vars ACSNOM and SNOW from ARWPOST output file. Is it possible there could be a bug in ems_post routine with these variables when written in the .grb2 file?


Thank you!

JFMass
Posts: 4
Joined: Tue Dec 02, 2014 12:50 am

Re: Problems with weasdsfc and snow melt in grib files

Post by JFMass » Tue Dec 02, 2014 4:01 pm

After further testing, it seems that INST_SFRAT from netcdf file is also not converting to grib correctly.

Here is an example with INST_SFRAT from netcdf file (top image) and SRATEsfc from grib file (bot image). Both values have been multiplied by 360 to make it cm/h instead of mm/s. I have like a 10X factor between both maps, but it isn't exactly X10 because some values from netcdf and above 6 cm/h while values from grib are below 0.5 cm/h.

The reason why I don't want to produce images from netcdf files is that images processing is done on another server and I need to move files from a server to the other.

Image


Image

Post Reply