Pressure levels too close together

Questions and other topics related to UEMS 18.
Post Reply
norulz
Posts: 128
Joined: Thu Mar 12, 2015 1:43 pm

Pressure levels too close together

Post by norulz »

I often suffer a crash at the end of creating initial and boundary conditions and the log shows:

Code: Select all

d01 2022-07-09_11:00:00          flag_soil_layers read from met_em file is  1
Using sfcprs2 to compute psfc
*** -> Check your wrfinput_d01 file, you might have input pressure levels too close together ( 19504.76 Pa and  19499.26 Pa) at ( 124,   5) for variable type Z
*** -> Check your wrfinput_d01 file, you might have input pressure levels too close together ( 19504.76 Pa and  19499.26 Pa) at ( 124,   5) for variable type T
forrtl: error (65): floating invalid
Image              PC                Routine            Line        Source             
real_arw.exe.inte  0000000002FC446B  Unknown               Unknown  Unknown
libpthread-2.31.s  000014F233F98140  Unknown               Unknown  Unknown
real_arw.exe.inte  0000000002F9B88E  Unknown               Unknown  Unknown
real_arw.exe.inte  000000000044C855  Unknown               Unknown  Unknown
real_arw.exe.inte  000000000048883F  Unknown               Unknown  Unknown
real_arw.exe.inte  00000000004A0CCD  Unknown               Unknown  Unknown
real_arw.exe.inte  000000000040BE8E  Unknown               Unknown  Unknown
real_arw.exe.inte  000000000040A5A2  Unknown               Unknown  Unknown
libc-2.31.so       000014F233CA1D0A  __libc_start_main     Unknown  Unknown
real_arw.exe.inte  000000000040A4A9  Unknown               Unknown  Unknown
I have tried changing layers setting and find no solution. The run succeeds with the next cycle of initialization files.

Does anyone have a remedy?
David
norulz
Posts: 128
Joined: Thu Mar 12, 2015 1:43 pm

Re: Pressure levels too close together

Post by norulz »

The following changes in run_conf settings have, so far, solved the recurring problem in a domain with mountainous areas

In run_wrfreal.conf:
USE_MAXW_LEVEL = 0 and USE_TROP_LEVEL = 0 (Back to default settings and not the UEMS new recommendations)

In run_levels.conf:
LEVELS = 41, PTOP = 1000, AUTO_LEVELS_OPT = 2, MAX_DZ = 1500, DZSTRETCH_S = 1.3, DZSTRETCH_U = 1.1

This appears to give more stable level settings
norulz
Posts: 128
Joined: Thu Mar 12, 2015 1:43 pm

Re: Pressure levels too close together

Post by norulz »

Crashed again.
This time AUTO_LEVELS_OPT = 1 appears to have solved the problem.
Post Reply