Page 1 of 2

Intel libraries

Posted: Sat Mar 09, 2019 4:00 pm
by alfe
Hello,
Are the exe compiled for Intel libraries working for anybody ?
I could not let them work on my system, although ldd command returns a correct diagnostic.

Thanks,

Re: Intel libraries

Posted: Mon Mar 25, 2019 9:10 pm
by pattim
They did not work for me. They passed the suggested test, also.

Re: Intel libraries

Posted: Mon Apr 15, 2019 4:28 pm
by pattim
Update on this - I downloaded the latest version (19) and ran the benchmark case on a single machine and the intel compiled version worked fine. When I tried to run it across my (infiniband) cluster, then it failed with a segfault, although the PCI compiled version ran fine. I therefore suspect that somehow not all the machines are finding the GLIB C libraries it needs. The head node passes the ldd wrfm_arw.exe.intel test, and I tried running that test from all nodes in the cluster, but that just appears to point back to the head node of my cluster, so it's a bit difficult to trouble-shoot.

Note: the intel-compiled version appears to be about 20% faster than the PCI-compiled version (!!!) on my X5680 CPUs (at least on a single node: without using infiniband on a cluster).

In the LOOKATME file, Robert mentions segfaults may come from incorrect hosts file setup - this is what sysinfo yields - for some reason the System Address field has issues. I don't know where that field comes from in terms of why Robert's script sysinfo can't find the host IP address - does anyone know? My hosts file looks correct to me. Suggestions? Anyone?

Code: Select all

    ☺  Collecting information about the machine known as "linux-68t00.local"

        System Information for linux-68t00.local
        
            System Date           : Mon Apr 15 16:52:41 2019
            System Hostname       : linux-68t00
            System Address        : None available
hosts file (the head node is 192.166.1.1)

Code: Select all

127.0.0.1       localhost
192.166.1.1     linux-68t00 linux-68t00.local
192.166.1.2     linux-68t10
192.166.1.3     linux-68t30
192.166.1.4     linux-68t20
::1     localhost ipv6-localhost ipv6-loopback
fe00::0 ipv6-localnet
ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts

Re: Intel libraries

Posted: Thu Apr 18, 2019 7:16 am
by emsiwx
Hi All,

I have tested Intel bins on my two i9-9980xe and one i9-9820x.

Works fine for some domain settings, crashes on another ones.
So I am using Intel for configs which work, and PGI for the others.

Intel bins definitelly don't work on my XEON CPU.

Marian

Re: Intel libraries

Posted: Sun Apr 21, 2019 7:17 pm
by pattim
Ah, I see - issues with Xeons maybe. No, wait, that isn't true - the INTEL exe ran perfectly on a single Xeon node with 12 processors while running the benchmark case. The only problem happened when trying to run across two or more nodes. I'll try again and try to report the error.

Re: Intel libraries

Posted: Sat May 11, 2019 5:01 pm
by pattim
Update on version 19 - the intel version of the WRF executable works well on one and two nodes of my cluster. I was unable so far to use more nodes. I use infiniband cards in the back of each node and simply string them together (no router) and that may be the problem, since there are several ports which are "bridged" in linux and mpich doesn't do well across multiple ports?

The intel executables are up to 50% faster (!!!) and with that kind of speed, I can use fewer nodes. I'll keep experimenting to see why I haven't been able to get them to work across all nodes.

Interestingly, spectral nudging only seems to work with 1 tile per CPU. Is that known?

pattiM

Re: Intel libraries

Posted: Sun May 12, 2019 10:54 am
by alfe
Hello,
It still doesn't work on my machine. Intel Core i7 8086K

I have tried to compile WRF from scratch with the intel compiler, last version 2019, old version 2015 , intermediate version 2017 : but same problem. Same SIGSERV error 174. :evil:

Re: Intel libraries

Posted: Wed May 15, 2019 12:44 am
by pattim
Bummer. What version are you running?

Re: Intel libraries

Posted: Thu May 16, 2019 6:21 pm
by alfe
Hello Pattim,
It is V 19.5.1.

I have asked Robert but he doesn't know how to troubleshoot it :(

Re: Intel libraries

Posted: Thu May 16, 2019 7:36 pm
by meteoadriatic
Hi,

does it work with files I sent to you?