Help! network problem - is there a wizard in the house?

Forum dedicated to older versions of EMS package (WRFEMS v3.2, v3.1 or older). Support is user-to-user based, so please help others if you can.
meteoadriatic
Posts: 1574
Joined: Wed Aug 19, 2009 10:05 am

Re: Help! network problem - is there a wizard in the house?

Post by meteoadriatic » Wed Jul 04, 2012 7:30 pm

pattim wrote:EDIT: can I do a wget *.* from that url?
Try something like:

Code: Select all

wget -r -nH --no-parent http://soostrc.comet.ucar.edu/wrfems/releases/3.2.1.5.45.beta

pattim
Posts: 173
Joined: Sun Jun 24, 2012 8:42 pm
Location: Los Angeles, CA, USA

Re: Help! network problem - is there a wizard in the house?

Post by pattim » Wed Jul 04, 2012 7:34 pm

meteoadriatic wrote:
pattim wrote:EDIT: can I do a wget *.* from that url?
Try something like:

Code: Select all

wget -r -nH --no-parent http://soostrc.comet.ucar.edu/wrfems/releases/3.2.1.5.45.beta
Global weather prediction as a citizen mandate. Now, how do we go about getting the EMS developers nominated for a Nobel? Or at least free pizza. ;)

pattim
Posts: 173
Joined: Sun Jun 24, 2012 8:42 pm
Location: Los Angeles, CA, USA

Re: Help! network problem - is there a wizard in the house?

Post by pattim » Thu Jul 05, 2012 2:07 am

Does anyone have any idea what the world is going on here? Why do two seemingly identical requests get entirely different results? Is the EMS server trying to send something back that the GISS server isn't? This is completely reproducible so it must be a server-side issue, is that not true? (The GISS server wget request works for binary files also.)

patti@TYAN:~/00_GCMs/EMS_WRF> wget http://portal.nccs.nasa.gov/GISS_modelE ... ar2009.txt
--2012-07-04 19:01:18-- http://portal.nccs.nasa.gov/GISS_modelE ... ar2009.txt
Resolving **********************.****.*** (**********************.****.***)... ***.***.***.***
Connecting to **********************.****.*** (**********************.****.***)|***.***.***.***|:****... connected.
Proxy request sent, awaiting response... 200 OK
Length: 7745 (7.6K) [text/plain]
Saving to: `GHG.Mar2009.txt.1'
100%[===========================================>] 7,745 --.-K/s in 0.002s
2012-07-04 19:01:18 (4.52 MB/s) - `GHG.Mar2009.txt.1' saved [7745/7745]
patti@TYAN:~/00_GCMs/EMS_WRF>
patti@TYAN:~/00_GCMs/EMS_WRF>
wget http://soostrc.comet.ucar.edu/wrfems/re ... .5.45.beta
--2012-07-04 19:01:28-- http://soostrc.comet.ucar.edu/wrfems/re ... .5.45.beta
Resolving **********************.****.*** (**********************.****.***)... ***.***.***.***
Connecting to **********************.****.*** (**********************.****.***)|***.***.***.***|:****... connected.
Proxy request sent, awaiting response... 407 Proxy Authentication Required
2012-07-04 19:01:28 ERROR 407: Proxy Authentication Required.
patti@TYAN:~/00_GCMs/EMS_WRF>
patti@TYAN:~/00_GCMs/EMS_WRF>


Oh, wait a minute - that's a directory (not a file) on the EMS request...

UPDATE:

Code: Select all

patti@TYAN-III:~> wget http://soostrc.comet.ucar.edu/wrfems/releases/3.2.1.5.45.beta/release.3.2.1.5.45.beta.allbin.x32.tbz
--2012-07-05 11:36:13--  http://soostrc.comet.ucar.edu/wrfems/releases/3.2.1.5.45.beta/release.3.2.1.5.45.beta.allbin.x32.tbz
Resolving **********************.****.*** (**********************.****.***)... ***.***.***.***
Connecting to **********************.****.*** (**********************.****.***)|***.***.***.***|:****... connected.
Proxy request sent, awaiting response... 407 Proxy Authentication Required
2012-07-05 11:36:13 ERROR 407: Proxy Authentication Required.
patti@TYAN-III:~> 
OK, I think this means that it is a server-side issue since command-line wget's to other servers work OK. Is the SOO's server sending an unusual response to the wget query? I think it's unlikely, but does the SOO server have its own proxy?

Post Reply