NCEP/GFS Version Update 12 June, 2019 at 1200 UTC

Questions and other topics related to UEMS 18.
Post Reply
rob
Posts: 8
Joined: Fri Oct 20, 2017 8:16 am

NCEP/GFS Version Update 12 June, 2019 at 1200 UTC

Post by rob » Mon May 27, 2019 9:21 am

Hi,
how should this be managed in UEMS?
Thanks
Roberto
Date: Fri, 24 May 2019 14:15:17 -0600
From: WRFHelp-NCAR <wrfhelp@ucar.edu>
To: wrf-news@ucar.edu
Subject: [Wrf-news] NCEP/GFS Version Update 12 June, 2019 at 1200 UTC
Message-ID: <DF5FE9FE-718D-41E9-B4FE-E195B7508D94@ucar.edu>
Content-Type: text/plain; charset="us-ascii"

If you do not use the GFS forecast product, this email probably does not concern you. If you do, please read on.

As you may be aware, NCEP is upgrading GFS from version 14 to 15.1 beginning with the 1200 UTC run on June 12, 2019. At that time, there will also be a chance with the real-time data product. This includes available pressure levels, file size, and the data directory structure. For the data directory change and the full description of the GFS upgrade, please see https://www.weather.gov/media/notificat ... _v15_1.pdf <https://www.weather.gov/media/notificat ... _v15_1.pdf>

To handle the new GFS data, you must use the ungrib program from WPS V4.0 or later. You do not need to upgrade other programs to later versions. The output from the newer ungrib will work with metgrid and the WRF model from earlier versions. To do so, you can download WPS Version 4.0 or later, place it in appropriate directory, then type 'configure' and 'compile ungrib'. This will only build the program ungrib.exe. After you run metgrid, check the values for 'num_metgrid_levels' using ncdump. If you do not use the supplementary pressure level data, num_metgrid_levels will change (from 32) to 34 with the new data. You can also use the new namelist option pmin (unit Pa) for ungrib to limit the pressure level data ungrib processes. If you set pmin = 1000, then you will get 29 pressure levels.

meteoadriatic
Posts: 1584
Joined: Wed Aug 19, 2009 10:05 am

Re: NCEP/GFS Version Update 12 June, 2019 at 1200 UTC

Post by meteoadriatic » Mon May 27, 2019 6:18 pm

If you have new version (with WPS/WRF 4.0 or 4.1) then all is fine. If you still use older EMS with WRF 3.9 or older, you will have to upgrade ungrib binary to v4.0 or v4.1.

rob
Posts: 8
Joined: Fri Oct 20, 2017 8:16 am

Re: NCEP/GFS Version Update 12 June, 2019 at 1200 UTC

Post by rob » Mon Jun 03, 2019 5:45 pm

Thanks.
I have updated to 19.5.1 but now I have a problem:

Code: Select all

  Starting UEMS Program ems_run (V19.5.1) on DUMMY at Mon Jun  3 17:34:11 2019 UTC

...

         !  From Your EMS UDoctor:

            Unable to determine number of soil levels in met_em.d01.2019-06-01_00:00:00.nc
In previous versions I also had this problem but I could solve it by using a different Vtable file:

Code: Select all

cd /path/to/uems/data/tables/vtables
curl http://www2.mmm.ucar.edu/wrf/src/Vtable.GFS_new > Vtable.GFS_new
mv Vtable.GFS Vtable.GFS.ori
ln -s Vtable.GFS_new Vtable.GFS 
Now this solution does not work anymore. How can I circumvent this problem?

Thank you.
Roberto
Last edited by rob on Tue Jun 04, 2019 9:05 am, edited 1 time in total.

rob
Posts: 8
Joined: Fri Oct 20, 2017 8:16 am

Re: NCEP/GFS Version Update 12 June, 2019 at 1200 UTC

Post by rob » Tue Jun 04, 2019 9:05 am

Ok, I found it. I forgot to update Vtable.FNL, too:

Code: Select all

mv Vtable.FNL Vtable.FNL.ori
ln -s Vtable.GFS_new Vtable.FNL

Post Reply